RotoMetals2MidSouth Shooters SupplyGraf & SonsLee Precision
StainLess Steel MediaTitan ReloadingInline FabricationADvertise here

Page 1 of 4 1234 LastLast
Results 1 to 20 of 66

Thread: Any pre-turbo 7.3 diesel mechanics out there?

  1. #1
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949

    Any pre-turbo 7.3 diesel mechanics out there?

    I have a '92 Ford 4x4 with a 7.3 diesel. This is an OLD 7.3. Has a sticker on the valve cover from International and the engine paint is gray. No turbo. I've owned it for 15 years and had very little trouble with it. It sits quite a bit, so I start it and drive it one day every 3 weeks or so. It's been -0- or below overnight most every night for a couple of weeks. Plugged the truck in this morning and let it warm for 4 hours. Let the glow plugs warm 2x, hit the starter and it fired right off. Ran for about 2 seconds and shut-down like I'd turned the key off. Now it won't restart.

    I have verified that the glow plugs are working. Removed the bottom cover on the fuel filter. No trace of ice and the fuel looks great, no sign of gelling at all. I use Power Service year round and change the filter regularly. I've never had a fuel problem. As I crank the engine, I see no smoke from the exhaust at all. I'm thinking there is a fuel delivery problem.

    I have a Haynes Diesel service manual I bought when I bought the truck, but as usual it's long on 'fluff' and short on specific details.

    The Haynes manual speaks of a low pressure fuel transfer pump, but doesn't mention where it is located on the truck, or if it is mechanical or electric. I presume the prior, but I don't know. Does anybody know if there is, in fact, a low pressure fuel transfer pump? If so, where is it and how should I go about testing it?

    I believe later model turbo diesel information will not be of any help to me.

    Thanks for looking, and I'd appreciate any help someone 'in the know' would offer.
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  2. #2
    Boolit Master
    rancher1913's Avatar
    Join Date
    May 2015
    Location
    plains of colorado
    Posts
    1,558
    If you pull the fuel line off and crank, does fuel come out

  3. #3
    Boolit Master


    BUCKEYE BANDIT's Avatar
    Join Date
    Aug 2013
    Location
    20 mi. W. of Camp Perry
    Posts
    290
    Low pressure pump in on passenger side front of engine. It is mechanical,are there dual tanks on the truck??.Just follow the steel line from the filter housing down.
    "The remedy for evil men is not the abrogation of the rights of law abiding citizens. The remedy for evil men is the gallows." Thomas Jefferson

  4. #4
    Boolit Master

    jcren's Avatar
    Join Date
    Nov 2014
    Location
    South, Central Ok
    Posts
    1,532
    Sounds like gelled diesel. When I ran traveling construction, we had one that we fueled up in south Tennessee and ran to north Nebraska during a cold spell that would not start the next day. Northern climates add anti-gel to diesel during cold months, so if the fuel was left over from summer, might be the problem.
    "In God we trust, in all others, check the manual!"

  5. #5
    Boolit Master
    Join Date
    Oct 2010
    Location
    fairbanks
    Posts
    9,019
    Air intrusion, I am very surprised you have never had this trouble before. That is if you are positive fuel is not gelled.
    Pull your filter, I am betting that it is not full to the top, and it cranked and ran for a few seconds on what fuel was in the injector pump, before the air hit it.
    9 times out of 10, the orings in the returnline caps are the culprit, but there is other areas that are common on them too, like the fuel heater connection on the filter.

  6. #6
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Quote Originally Posted by rancher1913 View Post
    If you pull the fuel line off and crank, does fuel come out
    Oy.

    Good question, Sir. The low pressure transfer pump is apparently working at it squirts fuel out of the 3/8" line a foot or so. I presume at cranking speed, that's probably OK. (?)

    How do I check a high pressure line? Just pull one off an injector and see how far the stream shoots?
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  7. #7
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Quote Originally Posted by jcren View Post
    Sounds like gelled diesel. When I ran traveling construction, we had one that we fueled up in south Tennessee and ran to north Nebraska during a cold spell that would not start the next day. Northern climates add anti-gel to diesel during cold months, so if the fuel was left over from summer, might be the problem.
    Just checked and it's not jelled. Low pressure transfer pump squirts fuel a foot or so when cranking.
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  8. #8
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Quote Originally Posted by starmac View Post
    Air intrusion, I am very surprised you have never had this trouble before. That is if you are positive fuel is not gelled.
    Pull your filter, I am betting that it is not full to the top, and it cranked and ran for a few seconds on what fuel was in the injector pump, before the air hit it.
    9 times out of 10, the orings in the returnline caps are the culprit, but there is other areas that are common on them too, like the fuel heater connection on the filter.
    Fuel is definitely not jelled. Pulled the inlet line to the fuel filter and the low pressure transfer pump shoots fuel a foot or so when cranking and it's definitely not jelled.

    Ok, I believe this could be the problem. What do I do to find/fix it?
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  9. #9
    Boolit Master
    Join Date
    Feb 2010
    Location
    northeastern washington
    Posts
    224
    my 93 did the same , i traced it to the return line from injectors to fuel filter. this is also tee'd to the return to the tanks. local diesel shop told me that only ford returned to the racor filter [IH did not] and the check valve at the filter will fail and take in air from any leak in the return line. i disconected the return at the filter and plugged the check valve fitting, no problem since.
    Shaune509

  10. #10
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Quote Originally Posted by shaune509 View Post
    my 93 did the same , i traced it to the return line from injectors to fuel filter. this is also tee'd to the return to the tanks. local diesel shop told me that only ford returned to the racor filter [IH did not] and the check valve at the filter will fail and take in air from any leak in the return line. i disconected the return at the filter and plugged the check valve fitting, no problem since.
    Shaune509
    Sending you a PM. Thanks!
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  11. #11
    Boolit Master
    Join Date
    Oct 2010
    Location
    fairbanks
    Posts
    9,019
    Napa or about any decent parts house carries fuel return line kits, but will give you the deer in the headlights look when you ask for one. They are in the computer as an injector install kit.
    The kit consists of the return line T's new fuel line, the orings and the copper injector washers, the washers are not used to just do return lines.
    The line will have to be cut to length, iirc it is 4 1/8 inch between injectors, but best to measure the old ones, as it has been a few years since I have done one.
    The reason this is common on these is that the heat hardens the orings ten minutes after you crank one of these, if the line is ever disturbed (bumped) it wiggles the T and usually causes a leak, for this reason you can not do one injector, even if you think you know which one it is. I am surprised that you have never had to change them before, especially since it is hard to change the glow plugs without disturbing the return lines..
    Have you checked at the schraeder valve while someone cranked the engine over to see if there is air or straight fuel, there should be NO air at all coming out of the filter.

  12. #12
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Quote Originally Posted by starmac View Post
    Napa or about any decent parts house carries fuel return line kits, but will give you the deer in the headlights look when you ask for one. They are in the computer as an injector install kit.
    The kit consists of the return line T's new fuel line, the orings and the copper injector washers, the washers are not used to just do return lines.
    The line will have to be cut to length, iirc it is 4 1/8 inch between injectors, but best to measure the old ones, as it has been a few years since I have done one.
    The reason this is common on these is that the heat hardens the orings ten minutes after you crank one of these, if the line is ever disturbed (bumped) it wiggles the T and usually causes a leak, for this reason you can not do one injector, even if you think you know which one it is. I am surprised that you have never had to change them before, especially since it is hard to change the glow plugs without disturbing the return lines..
    Have you checked at the schraeder valve while someone cranked the engine over to see if there is air or straight fuel, there should be NO air at all coming out of the filter.
    If there is a Schrader valve on this old dog, I've yet to notice it. All the fuel lines still have the gray paint on them from 1992, so I've no doubt the kit you're talking about is a good place to start. I'll call the NAPA warehouse Monday and hopefully, someone there will know what kit I need. 330,000 miles and 25 years? Not too shabby . . . . Never changed a glow plug, either. Though I did have to clean and tighten the connections on the glow plug controller once about 8 years ago.

    Last time I left the rock quarry, the truck, trailer and load grossed 22,350 lbs.

    Not too shabby . . .

    Thanks to everyone, I really appreciate it!
    Last edited by Hannibal; 01-06-2018 at 08:42 PM.
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  13. #13
    Boolit Master enfield's Avatar
    Join Date
    Feb 2007
    Location
    Nova Scotia
    Posts
    679
    I'm assuming your in a cold climate if your thinking about jelled fuel & glow plugs ( both good things to rule out ). I Know at one time the crank / cam position sensors would fail and give you a no start , If it has a tach, does it move while your cranking it over ? if not then the sensor could be the problem.

    hey, watch where ya point that thing!

  14. #14
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    No Tach. I'm hoping the fuel line/'O'-ring issue raised above is the culprit. Seems these old 7.3s were plagued with such issues, so either way it's a needed maintenance.

    Rest assured, If I repair the fuel lines and the doggone thing still won't start, I'll be back with more ???.
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  15. #15
    Quote Originally Posted by Hannibal View Post
    If there is a Schrader valve on this old dog, I've yet to notice it.
    Schrader valve should be on the fuel filter head if I recall correctly. Use it to bleed air out of the lines while cranking the engine. Good luck.

  16. #16
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Quote Originally Posted by BMW Rider View Post
    Schrader valve should be on the fuel filter head if I recall correctly. Use it to bleed air out of the lines while cranking the engine. Good luck.
    I'll look again tomorrow. Thanks for the post.
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  17. #17
    Boolit Master
    Plate plinker's Avatar
    Join Date
    May 2012
    Location
    Indiana
    Posts
    1,687
    I own diesel too good luck with this.

    You have good advice and I am sure you will solve this problem. After all it is a simple machine.
    Last edited by Plate plinker; 01-06-2018 at 11:22 PM.

  18. #18
    Boolit Bub
    Join Date
    Mar 2015
    Posts
    20
    No smoke out the exhaust means no fuel to the injectors. The problem is going to be between the point where there is fuel and where there is no fuel. Just have to find that point.

    These are a fairly simple system. The transfer pump supplies fuel to the injection pump. The injection pump sends the fuel to the individual injectors at the correct time. it sounds like the transfer pump is working. Have you tried cracking an injector line, (loosing the nut a turn) and cranking the engine? A small amount of fuel should shoot out past the nut each time the injector is supposed to fire. If fuel no fuel comes out, try plugging the fuel return line from the injectors at the filer housing on the housing side. Let the line from the injectors hang open, or route it into a container. On the side of the fuel filter head should be a scharder valve, depress it while cranking the engine, when the housing is full of fuel, fuel will come out of it. Release the valve and crank the engine until fuel starts squinting out the loosened injector nut. Tighten the nut and the engine should start fairly quickly.

    I am thinking these had an electric fuel shut off on the injection pump. If so, is there system voltage to the terminal when the Key is on?

    Is the block heater working? O is pretty cold for this old girl to start with out help.

    Good luck.

  19. #19
    Boolit Master Hannibal's Avatar
    Join Date
    Sep 2013
    Location
    40 miles from nowhere and plum out in the sticks
    Posts
    949
    Block heater is working. No doubt about this.
    Low pressure transfer pump is working. No doubt about this.
    Glow plugs are working. No doubt about this.

    The injector pump is not 'qualified' at this point. Either it has failed, or air is being introduced somewhere.
    That is where I am at.
    Missing the target is not the worst thing you can do.
    Not taking the shot is.

  20. #20
    Boolit Mold
    Join Date
    Oct 2017
    Posts
    11
    pull the return line off the top of injection pump, remove that fitting, try starting the eng. fuel will leak out of fitting hole. if it starts, the fitting you took out is stopped up, from the drive ring in the injection pump coming apart.

    GOOD LUCK

Page 1 of 4 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Abbreviations used in Reloading

BP Bronze Point IMR Improved Military Rifle PTD Pointed
BR Bench Rest M Magnum RN Round Nose
BT Boat Tail PL Power-Lokt SP Soft Point
C Compressed Charge PR Primer SPCL Soft Point "Core-Lokt"
HP Hollow Point PSPCL Pointed Soft Point "Core Lokt" C.O.L. Cartridge Overall Length
PSP Pointed Soft Point Spz Spitzer Point SBT Spitzer Boat Tail
LRN Lead Round Nose LWC Lead Wad Cutter LSWC Lead Semi Wad Cutter
GC Gas Check